Quick Fix: Python Error When Removing PernixData FVP Host Extensions

Came across an issue this morning trying to remove old 2.0 PernixData FVP Host Extensions from an ESXi 5.5 Update 3a Host. When running the uninstall script I was getting the error shown below.

There is an old known issue with the version of Python that gets installed with the latest updates of ESXi 5.x and older versions of the FVP Host extensions.

FVP compatibility with ESXi 5.5, 5.1, and 5.0, and Python 2.7
Date announced: March 31, 2015
Upgrade issues exist with various ESXi 5.5, 5.1, and 5.0 releases that upgrade to Python 2.7, which is not compatible with FVP 2.5.0.1 or lower. Upgrading to any ESXi 5.5, 5.1, or 5.0 patch that upgrades the Python version to 2.7 (or later) requires an FVP upgrade to 2.5.0.2 or later. For additional information, please reference KB 1230.

That internal PernixData KB isn’t working at the moment, but I worked out a series of steps to get to a point where the FVP Extensions can be removed. If you have FVP installed with these versions:

  • FVP 1.5
  • FVP 2.0.0.0-3
  • FVP 2.0.1.0-5
  • FVP 2.5.0.0-1

You can apply the same steps to resolve the issue.

  1. Check the Status of the FVP Service
  2. Install over the top of the currently installed version at least 2.5.0.4-37360
  3. Reboot the Host
  4. Run the Uninstall Script

The Shell Dump is below of the steps above.

 

Leave a Reply