Tag Archives: vCener

vSphere 6.0 vCenter Server Appliance: Upgrading from 5.x

Like most VMware Junkies over the past 24 hours I’ve downloaded the vSphere 6.0 bits and had them ready and primed to deploy and discover all the new features. Given the nature of a .0 release (not withstanding Change Control) upgrading production systems won’t be happening any time soon…however I had an opportunity right away to upgrade the Zettagrid Lab VCSA 5.5 Appliance to the 6.0 Appliance.

No word if this upgrade is possible via the old school method shown above, however the basic run through of the upgrade process is that the new VCSA is deployed and then imports data and settings from the existing VCSA while living on temporary network settings. It then shuts down the old VSCA and assumes it’s IP Address.

Working through the Upgrade Process, you need to download VMware-VCSA-all-6.0.0-2562643.iso and mount the VCSA ISO (Thanks @grantorchard) and from there double click on vcsa-setup.htm.

If you haven’t installed the 6.0 Client Integration Plugin located in the \vcsa folder of the ISO close down the browser and run that.

Rerun the vcsa-setup.htm and you should get the Install/Upgrade page…for me in Chrome I have to allow an External Protocol Request.

From there you have the option to Install or Upgrade to VCSA 6.0. This is an Upgrade that was chosen at which point the installed kicks off and gives you some details on what version of the VCSA you can upgrade from.

Clicking on Ok we are now presented with the VCSA Deployment Menu. First step is to enter in a target ESXi Host…not a vCenter like I first did to get the error below!

Moving through the Steps, we enter in a Virtual Machine Name and then specify the Source Appliance details which again is all host based.

Set the Appliance Size

Select the Datastore and then move onto the Temporary Network Settings…the explanation of what’s happening can be seen in the description below

Once all the settings are reviewed click on finish and the installer does all the work. For me this took about 20-30 minutes…bearing in mind that this vCenter was not large so import times will vary. You do have the option to bring across all existing Statistics…checking that option will vary the install time depending on how much data you have.

NOTE: My install progress stalled on Start the vCenter Web Client but that was more likely due to me not following instructions. When you select your target ESXi Host it states that DRS should be switched to Manual during the install process…my assumption is that the the VCSA was brought up on a different host other than the one specified and the installer lost track of the VM and wasn’t able to confirm the completion.

Regardless of that, I was able to log into the Web Client and ensure all Services where in tact and that the upgrade was successful…however I did start to see some strange behaviours and login issues over the weekend. I rolled back and went through the upgrade again, this time ensuring DRS was set to Manual…and had a 100% successful outcome.

I now can enjoy the benefits of the Web Client and start to get a feel for vSphere 6.0.

http://www.vmware.com/files/pdf/vsphere/VMware-vSphere-Platform-Whats-New.pdf

https://www.vmware.com/support/pubs/vsphere-esxi-vcenter-server-6-pubs.html